Customers
Download
Links
Products
How to Order
Home Page


Cyrillic Technical Support
Cyrillic 2 Tech Support
Can I have more than one family open at a time?
A1

Yes! Cyrillic has a "Multiple document interface". This means that you can have several files open at once, allowing you to compare families and copy information between them.

Q2 What are the limitations of the software?
A2

 

Maximum number of Individuals
per family

10000

Spouses per person No limit
Sibs per pregnancy 6
Sibs drawn per sibship (only applies
when creating sibships)
25
Markers per chromosome 250
Markers per family 150
Number of alleles
16 - if phenotype and allele
names are alterable
40 - for numbered alleles
150 - if only allele names are
alterable
Phenotypes 820
Diseases No limit
Affection classes 25
Quantitative traits per locus 3
Quantitative loci per family 1

 

Cyrillic 2 can import the following data file types:

  • Standard Cyrillic format
  • Pedigree/Draw Macintosh
  • LinkSys Import/Export
  • Both varieties of MLINK pedigree files
  • CriMap format
  • An extended GEDCOM format

See Questions 13 and 14 for further information.

Q3 Can I run Cyrillic on my Macintosh?
A3

Cyrillic is designed for Microsoft Windows. However, if your Macintosh has a DOS card or SoftWindows (A Windows emulation application) you will be able to run Cyrillic.

Q4 My toolbar does not have Cut, Copy and Paste buttons as shown in the manual.
A4

The toolbar for Cyrillic 2 was designed to be used with a SuperVGA display. When it is run on a VGA display, some of the buttons are not displayed because of the limited display area. If you are unable to use SVGA mode, choose these commands from the Edit menu.

Q5 I am getting a General Protection Fault whenever I use Cyrillic.
A5

Please ensure you are using the latest release version of Cyrillic.  Free patches are available for versions 2.0.x and 2.1.x.  If these don't help then please contact us at support@cyrillicsoftware.com with full details of your problem.

Q6 Where can I get the LINKAGE or FASTLINK packages?
A6

We are grateful to Alejandro Schaffer for allowing us to distribute a version of FASTLINK suitable for use with Cyrillic's example files, such as the Breast Cancer example.

Download for Windows 95/98/NT

Download for Windows 3.1

The source code for these and other  programs (for example, Cri-Map, LINKAGE) are available from Web Resources for Genetic Linkage Analysis , courtesy of the Laboratory of Statistical Genetics at Rockefeller University. There are also links from here to other web and ftp sites around the world.

Q7 Can you give me precise details of what I need to with the file I have downloaded?
A7

If you run the downloaded file by double-clicking it you will be prompted to extract the files to either C:\FL4WIN32 (when running FL4WIN32.EXE) or C:\FL3WIN16 (when running FL3WIN16).  It is recommended that you accept this default directory.

To perform a linkage analysis:

Run Cyrillic and open your family file, ensuring that the data directory has been correctly set.

  • Choose File|Export->MLINK, select the markers to analyze and then navigate to e.g. C:\LINKAGE.

    Note, the Export File Location dialog also has check boxes to Run MLINK, Rewrite the locus file, and View the results (OUTFILE.DAT).

  • Follow through the remaining prompts, setting values as are appropriate to your analysis.
  • The analysis will proceed -- a DOS Window appears showing the progress of the analysis. A successful run is usually accompanied by a long scrolling list of results in this window.
  • If prompted, close the DOS window and the results will be displayed in NOTEPAD. You can view the results at a later date in e.g. C:\LINKAGE\OUTFILE.DAT

To perform a Breast Cancer analysis:

Run Cyrillic using the "Breast Cancer Example" icon and open your family file, or the example file BRCA.FAM

Choose "Data|Run BrCa- Breast Cancer Susceptibility"

The analysis will now run to completion without any further prompting.  See the Breast Cancer Module page.

Q8 How can I increase the size of the text on printouts of alphabetic and numeric lists?
A8

Choose File|Print Options|Setup|Options and then change the Scaling of the output, say, to 125 percent.

Q9 How can I make the symbols larger on a printout?
A9

Use the Print Preview Option. In this mode, you can increase or decrease the size of the family in relation to the original using the percentage zoom drop-down list, in the toolbar as well as other useful features such as scale to fit and the ability to position the pedigree over a number of pages.

You can also make symbols larger without rescaling the drawing by modifying the Symbol Width attribute under the Display Format menu.

Q10 Is it possible to delete parents without losing their offspring?
A10

If you delete parents, Cyrillic will be unable to establish that the siblings are related. You can hide individuals, rather than delete them in order to maintain relationships between individuals. You can either hide partners from the display (See Options menu) or, in the Print Options dialog box you can choose Ignore Nameless Persons whenever you are printing a list.

Q11 Is there a way to indicate that someone is deceased without putting "?" or a death date in the Date of Death field (individual Data Dialog)
A11

No. However, because you control what information is shown on the pedigree, you do not need to display the date on-screen (See Format|Display Format).

Q12 Where can I find out more information about the GEDCOM format?
A12

The GEDCOM standard release v5.5 manual can be viewed online. The current official GEDCOM documents are available at at ftp.gedcom.org .

Q13 Is it possible to import data into Cyrillic from a database?
A13

The easiest way to import information from a database into Cyrillic 2 is to export your data as an ASCII file (Plain text file) with the information arranged within that file in one of the formats supported by Cyrillic 2. You will need to set up a "macro" or "export filter" that will allow you to automate the procedure of automatically formatting the ASCII output from your database into one of the eight popular genetic file formats supported by Cyrillic 2. However, you will need to investigate yourself as to how to set up such macros/filters - please refer to the documentation that comes with your database program.

You will need to manipulate your ASCII files to match the GEDCOM format if you want rich and extensive data transfer. However, if you just need basic patient information and marker details then we advise following the Standard Cyrillic format.

Another option would be to export a plain ASCII file from your database, open it in a text editor (such as Word, or Windows Notepad) and manually change the format to match that of your chosen import format although this can sometimes be rather time-consuming.

You can find more information about this whole topic beginning on page 120 of the Cyrillic 2.0 manual - all of the import formats are also described in detail in this particular section.


Cyrillic 2 Popular Questions
Multiple families open
Software limitations
Running Cyrillic on a Mac
Cut, copy, paste in toolbar
Patch for General
Protection Fault in 2.0
LINKAGE and FASTLINK
Where to put download files for use with Cyrillic
Increase text size
Make symbols larger on printout
Hide vs Delete offspring Indicating a death
More about GEDCOM format
Cyrillic 2 files and databases
Tech Support by e-mail
For technical support by Email, visit: 

Technical Support Pages

 

 

 

 

 

 

Customers | Download | Links | Products | How to Order | Home Page

 
  Technical Support | Contact Us  
  CyrillicSoftware 2000